静态路由

编辑 锁定
静态路由是指由用户或网络管理员手工配置的路由信息。当网络的拓扑结构或链路的状态发生变化时,网络管理员需要手工去修改路由表中相关的静态路由信息。静态路由信息在缺省情况下是私有的,不会传递给其他的路由器。当然,网管员也可以通过对路由器进行设置使之成为共享的。静态路由一般适用于比较简单的网络环境,在这样的环境中,网络管理员易于清楚地了解网络的拓扑结构,便于设置正确的路由信息。
在一个支持DDR(Dial-on-Demand Routing)的网络中,拨号链路只在需要时才拨通,因此不能为动态路由信息表提供路由信息的变更情况。在这种情况下,网络也适合使用静态路由。
中文名
静态路由
外文名
Static routing
解 释
网络管理员手工配置的路由信息
使 用
网络

目录

  1. 1 优点
  2. 女人最容易离婚的性格 2 缺点
  1. 3 配置命令
  2. 4 举例
  1. 5 常见问题
  2. 6 配置路由

优点 编辑

使用静态路由的另一个好处是网络安全保密性高。动态路由因为需要女人最容易离婚的性格路由器之间频繁地交换各自的路由表,而对路由表的分析可以揭示网络的拓扑结构网络地址等信息。因此,网络出于安全方面的考虑也可以采用静态路由。不占用网络带宽,因为静态路由不会产生更新流量。

缺点 女人最容易离婚的性格编辑

大型和复杂的网络环境通常不宜采用静态路由。一方面,网络管理员难以全面地了解整个网络的拓扑结构;另一方面,当网络的拓扑结构和链路状态发生变化时,路由器中的静态路由信息需要大范围地调整,这一工作的难度和复杂程度非常高。当网络发生变化或网络发生故障时,不能重选路由,很可能使路由失败。

配置命令 编辑

(以右图为例)
静态路由的配置有两种方法:带下一跳路由器的静态路由,和带送出接口的静态路由
router(config)#hostname A (更改路由器女人最容易离婚的性格主机名A(config)#interface f0/0 (进入接口f0/0)
A(config-if)#ip address 192.168.1.1 255.255.255.0 (设置接口ip地址和子网掩码
A(config-if)#no shutdown (启用接口)
A(config)#interface f0/1
A(config-if)#ip address 192.168.2.1 255.255.255.0
A(config-if)#no shutdown
×××以下二选一:
A(config)#ip route 192.168.3.0 255.255.255.0 f0/1(目标网段IP地址 目标子网掩码送出接口(路由器A))
或者
A(config)#ip route 192.168.3.0 255.255.255.0 192.168.2.2 (目标网段IP地址 目标子网掩码下一路由器接口ip地址)
×××
router(config)#hostname B
B(config)#interface f0/0
B(config-if)#ip address 192.168.3.1 255.255.255.0
B(config-if)#no shutdown
B(config)#interface f0/1
B(config-if)#ip address 192.168.2.2 255.255.255.0
B(config-if)#no shutdown
×××以下二选一:
B(config)#ip route 192.168.1.0 255.255.255.0 192.168.2.1
或者:
B(config)#ip route 192.168.1.0 255.255.255.0 f0/1(目标网段IP地址 目标子网掩码送出接口(路由器B))
×××
注1:此网络链路为以太网链路,如果是串行链路,送出接口也就是本地路由器串行接口
简明解释:ip route 192.168.3.0 255.255.255.0 192.168.2.2
这句话的意思是:在HOSTA上,路由器见到目的网段为192.168.3.0的数据包,就将数据包发送到192.168.2.2上
注2:ip route 指向一个就可,如果两个都配了,就是说将这个数据包从发fa0/1出去,而另一个说数据包发到这个ip(例如192.168.2.2)。两个重复。一般我们设置为指向IP。

举例 编辑

基本的静态路由举例如图所示,由两个路由器R1和R2组成(接口号和IP地址在图中给出),它们分别连接了各自的网络:R1连接了子网192.168.0.0/24,R2连接了子网192.168.2.0/24[1]
在没有配置静态路由的情况下,这两个子网中的计算机A、B之间是不能通信的。从计算机A发往计算机B的IP包,在到达R1后,R1不知道如何到达计算机B所在的网段192.168.2.0/24(即R1上没有去往192.168.2.0/24的路由表),同样R2也不知道如何到达计算机A所在的网段192.168.0.0/24,因此通信失败。
此时就需要管理员在R1和R2上分别配置静态路由来使计算机A、B成功通信。
  • 在R1上执行添加静态路由的命令ip route 192.168.2.0 255.255.255.0 192.168.1.1。它的意思是告诉R1,如果有IP包想达到网段192.168.2.0/24,那么请将此IP包发给192.168.1.1(即和R1的2号端口相连的对端)。
  • 同时也要在R2上执行添加静态路由的命令ip route 192.168.0.0 255.255.255.0 192.168.1.2。它的意思是告诉R2,如果有IP包想达到网段192.168.0.0/24,那么请将此IP包发给192.168.1.2(即和R2的3号端口相连的对端)。
通过上面的两段配置,从计算机A发往计算机B的IP包,能被R1通过2号端口转发给R2,然后R2转发给计算机B。同样地,从计算机B返回给计算机A的IP包,能被R2通过3号端口转发给R1,然后R1转发给计算机A,完成了一个完整的通讯过程。

常见问题 编辑

1)为什么要有默认路由
路由得查看路由表而决定怎么转发数据包,用静态路由一个个的配置,繁琐易错。如果路由器有个邻居知道怎么前往所有的目的地,可以把路由表匹配的任务交给它,省了很多事。
例,网关会知道所有的路由,如果一个路由器连接到网关,就可以配置默认路由,把所有的数据包都转发到网关。
2)为什么默认路由是0.0.0.0
匹配IP地址时,0表示wildcard, 任何值都可以。所以0.0.0.0和任何目的地址匹配都会成功,造成默认路由要求的效果。

配置路由 编辑

配置路由器R1端口:
Router>en
  Router#config // 进入配置模式
  Configuring from terminal, memory, or network [terminal]? t
  Enter configuration commands, one per line. End with CNTL/Z.
  Router(config)#hostname r1//更改主机名为r1
  R1(config)#int f0/0 //配置端口f0/0
  R1(config-if)#ip add 192.168.1.1 255.255.255.0//设置端口ip
  R1(config-if)#no shut//打开端口
  %LINK-5-CHANGED: Interface FastEthernet1/0, changed state to up
  R1(config-if)#
  %SYS-5-CONFIG_I: Configured from console by console
  R1(config)#int f1/0//配置端口f1/0
  R1(config-if)#ip add 192.168.2.1 255.255.255.0//设置端口ip
  R1(config-if)#no shut//打开端口
  %LINK-5-CHANGED: Interface FastEthernet1/0, changed state to up
  配置路由器r2端口
  Router(config)#hostname R2//更改主机名为R2
  R2(config)#int f0/0 //配置端口f0/0
  R2(config-if)#ip add 192.168.2.2 255.255.255.0//设置端口ip
  R2config-if)#no shut//打开端口
  R2(config)#int f0/0 //配置端口f1/0
  R2(config-if)#ip add 192.168.3.1 255.255.255.0//设置端口ip
  R2(config-if)#no shut//打开端口
&n
  R2(config-if)#ip add 192.168.3.1 255.255.255.0//设置端口ip
  R2(config-if)#no shut//打开端口
  配置路由器R3端口
  Router(config)#hostname R3//更改主机名为R3
  R3(config)#int f0/0 //配置端口f0/0
  R3(config-if)#ip add 192.168.3.2 255.255.255.0//设置端口ip
  R3config-if)#no shut//打开端口
  R3(config)#int f0/0 //配置端口f1/0
  R3(config-if)#ip add 192.168.4.1 255.255.255.0//设置端口ip
  R3config-if)#no shut//打开端口
参考资料
  • 1. Jeff Doyle, CCIE #1919 葛建立 吴剑章 译.TCP/IP 路由技术 (第一卷)(第二版):人民邮电出版社,2007
词条标签:
中国通信学会 计算机学